[Bug 258192] devel/py-pyinstaller: version 3.5 in ports incompatible with python3.8

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 01 Sep 2021 05:44:01 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=258192

            Bug ID: 258192
           Summary: devel/py-pyinstaller: version 3.5 in ports
                    incompatible with python3.8
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: python_at_FreeBSD.org
          Reporter: russo_at_bogodyn.org
             Flags: maintainer-feedback?(python_at_FreeBSD.org)
          Assignee: python_at_FreeBSD.org

Version 3.5 of py-pyinstaller, currently in ports, is incompatible with python
3.8.  When one tries to use it, one gets a TypeError: 
https://github.com/pyinstaller/pyinstaller/issues/4580

They fixed this issue in version 4.1 of pyinstaller: 
https://pyinstaller.readthedocs.io/en/stable/CHANGES.html#id1

The current version of pyinstaller is 4.5 and it works with more recent python.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Wed Sep 01 2021 - 05:44:01 UTC

Original text of this message