[Bug 258192] devel/py-pyinstaller: Fails to run on 3.8+. Fix incorrect Python <version-spec>, then update to latest version

From: <bugzilla-noreply_at_freebsd.org>
Date: Mon, 06 Sep 2021 18:25:29 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=258192

--- Comment #7 from russo_at_bogodyn.org ---
As requested, I have attempted to patch the devel/py-pyinstaller port so that
it will install 4.5.1 instead of 3.5.

This was a heavy-handed patch, because upstream have stopped bundling the
documentation in the source tarball on PyPi.  It is still present in the Github
repo for the project (https://github.com/pyinstaller/pyinstaller), but I did
not want to try to modify the port to use the Github repo instead of
CHEESESHOP.

Thus, I had to remove all of the parts of the makefile pertaining to
documentation and man pages.

The new setup requires py-wheel, so I had to add that as a build depend.

I find, however, that USING pyinstaller now requires
"pyinstaller-hooks-contrib", which I did NOT create a port for.  I simply used
pip install to get at it, at which point pyinstaller now works correctly with
Python 3.8.

I will understand if this patch is too rough to be committed, but this is what
it took to get me back to work.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Mon Sep 06 2021 - 18:25:29 UTC

Original text of this message