boot hang with certain Phenom II cpu models

Marek Zarychta zarychtam at
Thu Dec 13 13:24:45 UTC 2018

W dniu 13.12.2018 o 11:56, Sascha Klauder pisze:
> Hi all,
>  I've recently upgraded my Athlon II based home box (happily
> running FreeBSD for several years) to a Phenom II X4 960T CPU.
> Now, kernel (11.2) hangs in early hardware initialization.
>  Mainboard is a nForce 720 based Gigabyte GA-M720-US3 rev 1.0,
> BIOS is latest and the CPU is on Gigabyte's CPU support list
> for this board. 
>  A parallel Windows 7 installation continues to work flawlessly
> and the system is stable running prime95.  Memtest86 reports no
> errors.  I've tried several other OS boot media (DragonFly 5.4,
> OpenBSD 6.4, Linux 4.9) -- all boot fine with no problems (see
> dmesg output linked below).
>  I've found two very similiar problem reports on the FreeBSD
> forums.  Both involve Phenom II cpu's and nForce-based mainboards,
> so I think we're missing some BIOS/ACPI quirk here.
>  So far, I tried (unsuccessfully) to disable obvious ACPI sub-
> systems (cpu, mwait, quirks) and debug settings (acpi.cpu_unordered,
> acpi.max_threads).  Anyone got a hint where to look or debug this
> further?
> kernel boot messages (obtained from 10.4 amd64):
> boot messages with the previous Athlon II cpu in this system:
> boot messages from DFly, OpenBSD and Linux:

Try to boot FreeBSD with GRUB2 as a workaround. My hardware configuration also suffered from similar issue[1] so I had never successfully booted FreeBSD using standard loader, but GRUB2 allowed to install and use FreeBSD on this PC.


Marek Zarychta

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-stable mailing list