boot hang with certain Phenom II cpu models

Sascha Klauder sascha at hosting.ntag.de
Thu Dec 13 11:15:41 UTC 2018


Hi all,

 I've recently upgraded my Athlon II based home box (happily
running FreeBSD for several years) to a Phenom II X4 960T CPU.
Now, kernel (11.2) hangs in early hardware initialization.

 Mainboard is a nForce 720 based Gigabyte GA-M720-US3 rev 1.0,
BIOS is latest and the CPU is on Gigabyte's CPU support list
for this board. 

 A parallel Windows 7 installation continues to work flawlessly
and the system is stable running prime95.  Memtest86 reports no
errors.  I've tried several other OS boot media (DragonFly 5.4,
OpenBSD 6.4, Linux 4.9) -- all boot fine with no problems (see
dmesg output linked below).

 I've found two very similiar problem reports on the FreeBSD
forums.  Both involve Phenom II cpu's and nForce-based mainboards,
so I think we're missing some BIOS/ACPI quirk here.
https://forums.freebsd.org/threads/10-1-installer-wont-boot-past-acpi.50015/
https://forums.freebsd.org/threads/boot-hangs-after-cpu-upgrade.64410/

 So far, I tried (unsuccessfully) to disable obvious ACPI sub-
systems (cpu, mwait, quirks) and debug settings (acpi.cpu_unordered,
acpi.max_threads).  Anyone got a hint where to look or debug this
further?

kernel boot messages (obtained from 10.4 amd64):
https://lair.griffinsplace.de/~sascha/phenom/dmesg-freeze-FreeBSD10.txt

boot messages with the previous Athlon II cpu in this system:
https://lair.griffinsplace.de/~sascha/phenom/dmesg-FreeBSD-AthlonII.txt

boot messages from DFly, OpenBSD and Linux:
https://lair.griffinsplace.de/~sascha/phenom/

Cheers,
-sascha


More information about the freebsd-stable mailing list