10.2-Beta i386..what's wrong..?

Holm Tiffe holm at freibergnet.de
Wed Jul 22 11:58:16 UTC 2015

..uh top quoting..

Trying to mount root from zfs:zroot/ROOT/default [].

Fatal double fault:
eip = 0xc0b416f5
esp = 0xe2673000
ebp = 0xe2673008
cpuid =0; apic id = 00
panic: double fault
cpuid = 0
KDB stack backtrace:
#0 0xc0b72832 at kdb_backtrace+0x52
#1 0xc0b339cb at vpanic+0x11b
#2 0xc0b338ab at panic+0x1b
#3 0xc10556 at dblfault_handler+0xab
Uptime: 11s

Don't know if I've blowing the stack, nor I have currently the capabilities
to build an 10.2-Beta install disk with an custom kernel.
I've simply tried to install freebsd on old (trusty) hardware to do some

In the meantime I've tested to install on the single disks with a plain ufs
in the existing gpart partitions (da?p3) und using the swapspace (da?p2).
That where 4 flawless installations, all 4 installed w/o any stall and
where bootable, so the hardware is ok.
Next try is gmirror on 2 gpart disks. I think gvinum is broken with gpart
partitions for since at least 9.3 on i386.



Steven Hartland wrote:

> What's the panic?
> As your using ZFS I'd lay money on the fact your blowing the stack, 
> which would require kernel built with:
> options KSTACK_PAGES=4
>     Regards
>     Steve
> On 22/07/2015 08:10, Holm Tiffe wrote:
> >Hi,
> >
> >yesterday I've decided to to put my old "Workstation" in my shack and
> >to install a new FreeBSD on it, it is the computer I've used previously
> >for my daily work, reading Mails, programming controllers and so on..
> >
> >It is am AMD XP300+ with an Adaptec 29320 and four IBM 72GB SCSI3 Disks
> >with only 2GB of Memory.
> >
> >I've replaced a bad disk, reformated it so 512 Byte sectors )they came
> >original with 534 or so for ecc),pulled the 10.2-Beta disk1 ISO file from
> >the german mirror and tried to install on a zfs raidz1 which was going
> >flawlessly until the point of booting the installed system, some warnings
> >about zfs and vm... double fault, panic.
> >
> >Later I've read on the net that installing zfs on a 32Bit machine isn't
> >really a good idea, so I tried to install the system on a gvinum raid
> >on gpt partitions.
> >The layout was gpt-boot, 2G swap and the rest raid on every disk so
> >that I could build a striped 8G swap and ~190G raid with gvinum.
> >Installing that worked flawlessly with the install point "shell and doing
> >partitioning per hand". I've made a newfs -U -L root /dev/gvinum/raid,
> >mounted the filesystem to /mnt, activated the swap and put an fstab in
> >/tmp/bsdsomething-etc, exited to install.
> >
> >The installer verified the install containers (base.txz,kernel.txz and
> >so on) and begun to extract them.
> >So far soo good, but while extracting the system repeatedly hung on the
> >very same location. On vt4 I could start a top that was showing an hung
> >bsdtar process in the state wdrain and nothing other happened, the system
> >took a long time to react to keypresses..
> >
> >I've tried to extract the distribution files per hand, same problem, tar
> >hung on extracting kernel.symbols for example, same behavior on other files
> >in base.txz.
> >
> >Ok, it is 10.2-BETA so I've tried 10.1-Release next...exactly the same,
> >ok tried 9.3-RELEASE .. the same!
> >
> >What I'm doning wrong here?
> >
> >Besides of the bad disk that I've changed (IBM-SSG S53D073 C61F) the
> >hardware is very trusty, it is a gigabyte board and I want to keep this
> >machine since it has still floppy capabilites that I need to comunicate
> >with my old CP/M gear and PDP11's. It run for years w/o problems.
> >Capacitors are already changed and ok.
> >
> >Sorry for the wishy-washy error messages above, they are from my memory and
> >from yesterday...
> >
> >Next try was installing the System on a 8G ATA disk that was laying around,
> >went flawlessly, booted it and tried to install the files on the gvinum
> >raid from there...same problem.
> >Changed the 29320 against a 29160 ..same problem.
> >No messages about bad disksor something on the console.
> >
> >What's going on here? The machine run on 8.4-stable before w/o any
> >problems.
> >
> >Regards,
> >
> >Holm
> _______________________________________________
> freebsd-stable at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-stable
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at freebsd.org"

      Technik Service u. Handel Tiffe, www.tsht.de, Holm Tiffe, 
     Freiberger Straße 42, 09600 Oberschöna, USt-Id: DE253710583
  www.tsht.de, info at tsht.de, Fax +49 3731 74200, Mobil: 0172 8790 741

More information about the freebsd-stable mailing list