Confused about i915kms on 12.1

Chuck Tuffli ctuffli at
Sun Oct 13 21:43:01 UTC 2019

Many thanks to Pete and John. See inline below

On Sun, Oct 13, 2019 at 1:13 PM John Kennedy <warlock at> wrote:
> On Sun, Oct 13, 2019 at 12:35:41PM -0700, Chuck Tuffli wrote:
> > I've been running 12.0-REL on my X1 Carbon 3rd Gen happily with xorg,
> > but after installing 12.1-RC1, the laptop reboots when loading the
> > i915kms driver. If I comment out the line in /etc/rc.conf:
> >
> > kld_list="/boot/modules/i915kms.ko"
> >
> > the laptop boots, albeit without graphics. The above comes from the
> > 12.0R release notes, and I didn't see any updates to this in the 12.1
> > release notes. I've tried drm-kmod from both ports and packages with
> > the same result. Did something change with 12.1? What should I check?
> > TIA
>   Not sure how your upgraded your box, but make sure that the driver is
> compiled for the new kernel.  KBI breakage can easily behave like that.

I upgraded the box per the release announcement:
   freebsd-update upgrade -r 12.1-RC1
   freebsd-update install
with the prescribed reboots and installs. Afterwards, I did a pkg
update and pkg upgrade. Note, I don't install anything from ports.

>   I won't be in front of a box with that setup until Monday, but from
> memory, graphics/drm-kmod pulls in graphics/drm-fbsd12.0-kmod (at
> least on my system with it's build-in Intel video card).
>   If you do something like this, but substitute your .ko file for m4
> below, you should be able to validate the package it came from and the
> kernel version it was targeted at:
>         $ pkg which /usr/local/bin/*m4
>         /usr/local/bin/gm4 was installed by package m4-1.4.18_1,1
>         $ pkg info m4 | grep -i version
>         Version        : 1.4.18_1,1
>                 FreeBSD_version: 1201000
>   That 1201000 means that it was compiled for 12.1 in my case.
$ pkg info drm-fbsd12.0-kmod-4.16.g20190814 | grep -i version
Version        : 4.16.g20190814
    FreeBSD_version: 1200086
This version is for FreeBSD 12.0.

>   Have you overridden the default package location, leaving it aimed at 12.0?


>   What do you mean by trying it from "ports"?  How did you refresh that?

The advice I received was 'you need to build drm-kmod from ports'. I
don't typically have a ports tree, so I did:
    # portsnap fetch
    # portsnap extract
    # cd /usr/ports/graphics/drm-kmod
    # make && make install
After doing the makes, my immediate thought was 'that finished too fast'.
If, instead, I follow Pete's advice and run make package in
/usr/ports/graphics/drm-fbsd12.0-kmod, a) make appears to do something
and b) the resulting package allows my laptop to boot to a graphical
desktop. And the FreeBSD_version looks correct:
$ pkg info drm-fbsd12.0-kmod-4.16.g20190814 | grep -i version
Version        : 4.16.g20190814
    FreeBSD_version: 1201000
This version is for FreeBSD 12.0.

I did go back and verify that a pkg install drm-kmod appears to
install the same (older) i915kms.ko as pkg install drm-fbsd12.0-kmod.
Out of curiosity, is the new world order that I'll always need to
compile drm-kmod from ports, or did I hit a window where packages
hadn't quite caught up to ports?


More information about the freebsd-stable mailing list