Problem with STABLE-12

Filippo Moretti filippomore at
Fri Apr 26 09:07:54 UTC 2019

 I tried buildworld today but it failed,I will try again later.Thanks for your helpFilippo

    On Thursday, April 25, 2019, 5:20:46 PM GMT+2, Paul Mather <paul at> wrote:  
 On Apr 25, 2019, at 10:07 AM, Filippo Moretti <filippomore at> wrote:

> Did you build world yesterday and now drm-kmod is working again?The only  
> problem I have with legacy both drm and ati is that smplayer crashes the  
> system and I have to reset via power switch.

I updated and installed kernel and world on Tuesday, mainly to bring in the  
clang 8.0.0 changes.  Then, yesterday, I saw graphics/drm-fbsd12.0-kmod  
listed when I did a portsnap update and so built it on the off-chance  
whatever had been updated in it would cause it to work again on my system.  
I replaced my existing graphics/drm-legacy-kmod with it, and the system did  
not hang in multiuser when trying to load the kmod.  The resultant console  
worked like before (when I used graphics/drm-kmod).

I just looked at the graphics/drm-kmod Makefile and  
graphics/drm-fbsd12.0-kmod is the port selected for my OSVERSION (1200507)  
when installing.



PS: I am only using graphics/drm-kmod for the system console, to get more  
text columns than the built-in 640x480 VGA console would otherwise allow.

> Filippo
> On Thursday, April 25, 2019, 4:00:00 PM GMT+2, Paul Mather  
> <paul at> wrote:
> On Apr 18, 2019, at 8:01 AM, Pete French <petefrench at> wrote:
> >
> >> I have a radeon graphics card, too.  Recently, I had a problem with the
> >> graphics/drm-kmod hanging on boot in multi-user.  My fix was to switch
> >> to graphics/drm-legacy-kmod, which at least lets the system boot again.
> >> I figure the newer graphics/drm-kmod no longer supports my old radeon
> >> card.
> >
> > So, I was about to post about this, and then saw this thread. I too ave
> > had to go back to the legacy-kmod because something broke it in the last
> > couple of weeks. Was using the new one fine until then. Unfortunately I
> > didnt know it was broken as have been working remotely and thus not in
> > front of the machine. But I doubt that the Radeon stopped being supported
> > soehow - that would be mentioned somewhere surely ? It looks like a hang
> > on loading the module to me.
> As of yesterday, the graphics/drm-fbsd12.0-kmod port is working for me[1].
> This is good news because a) the video quality is better, and, b) it
> supports colour, which graphics/drm-legacy-kmod didn't seem to.  (So now I
> get a green status bar again in tmux.)
> In other words, it may be that whatever broke in graphics/drm-kmod has now
> been fixed?
> Cheers,
> Paul.
> [1] At least working in FreeBSD 12.0-STABLE r346597.
> _______________________________________________
> freebsd-stable at mailing list
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"

freebsd-stable at mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"

More information about the freebsd-stable mailing list