Ryzen issues on FreeBSD ? (with sort of workaround)

Mike Tancsa mike at sentex.net
Tue Apr 24 14:22:50 UTC 2018

On 4/24/2018 10:01 AM, Pete French wrote:
> Well, I ranh the iperf tests between real machine for 24 hours and that
> worked fine. I also then spun up a Virtualbox with Win10 in it, and ran
> iuperf to there at the same time as doing it betwene real machines, and
> also did a full virus scan to exercise the disc. the idea being to
> replicate Mondays lockup.

I was able to lock it up with vbox. bhyve was just a little easier to
script and also I figured would be good to get VBox out of the mix in
case it was something specific to VBox.  I dont recall if I tried it
with SMT disabled.  Regardless, on Intel based systems I ran these tests
for 72hrs straight without issue.   I can sort of believe hardware issue
or flaky motherboard BIOSes (2 ASUS MBs, 1 MSI MB, 3 Ryzen chips), but
the fact that two server class MBs from SuperMicro along with an Epyc
chip also does the same thing makes me think something specific to
FreeBSD and this class of AMD CPU :(


Mike Tancsa, tel +1 519 651 3400 x203
Sentex Communications, mike at sentex.net
Providing Internet services since 1994 www.sentex.net
Cambridge, Ontario Canada

More information about the freebsd-stable mailing list