r284665 causes MSI problems -> ahcich2: Timeout in slot 11 port 0

Harald Schmalzbauer h.schmalzbauer at omnilan.de
Sun Jul 12 09:59:29 UTC 2015

 Bezüglich Edward Tomasz Napierała's Nachricht vom 12.07.2015 11:41
> On 0711T1956, Harald Schmalzbauer wrote:
>>  Hello,
>> r284665 causes ahci(4) to fail with timeouts when using MSI (the default).
> What's the hardware?

Thanks for your attention,

it's Intel Cougar Point (C204, 2x SATA6G+4xSATAII), via PCIe-Passthrough
in an ESXi guest.
Several of these setups have been in production with 9.2 and 10.1 for 2
years+ without ahcich timeouts.

>> 'hint.ahci.0.msi=0' is one way to make ahci(4) working with r284665, but
>> obviously not the desired solution, it just disables usage of an MSI.
>> I can't find suspicious code in r282213 which could cause this strange
>> regression, but I verified carefully that problem arises with r284665.
>> Actually, r282901
>> (https://svnweb.freebsd.org/base?view=revision&sortby=date&revision=282901)
>> is the real trigger, verified by putting
>> nooptions         RACCT
>> nooptions         RACCT_DEFAULT_TO_DISABLED
>> nooptions         RCTL
>> into my kernel config -> problem vanishes!
>> Setting "kern.racct.enable=1" doesn't make any difference, as soon as
>> 'kern.features.racct' exists, there's the ahci(4)/ahcich2 timeout and
>> machine doesn't finish booting.
>> Unfortunately, I don't have any idea how to track this down to the
>> actual culprit, but I hope the RACCT hackers do have ;-)
>> Shall I open a bugzilla ticket?
> That's... curious.  I don't see how those two things could be related.
> What's the FreeBSD version?  How reproducible it is?  Have you tried
> compiling with and without those three lines a couple of times?

Yes, I tried several times, and falsified that with r284665 the timeouts
reproducably show up (which blocks the booting process, a major issue in
my case).
I also verified that several different revisions <284665 don't lead to
that problem, and also that the changes in ahci code paths for the last
year are not involved.
I also can't see any relation, wich doesn't mean much since I don't have
the kernel skills, but I'm sure the symptoms start with "options RACCT"



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 196 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20150712/32214857/attachment.bin>

More information about the freebsd-stable mailing list