ports/base ntpd rc.d script with WITHOUT_NTP=yes

Adam McDougall mcdouga9 at egr.msu.edu
Wed Apr 8 16:56:22 UTC 2015

On 04/08/2015 12:48, Matt Smith wrote:
> Hi,
> I just upgraded my server to 10.1-STABLE r281264 and when I ran
> mergemaster it told me that /etc/rc.d/ntpd was stale and would I like to
> delete it. It's never done this before. I've figured out it's because I
> have WITHOUT_NTP=yes in /etc/src.conf. I did this because I use the
> ports version of ntpd and thus wanted to remove the base installed
> version so that when I run commands like ntpq it's using my possibly
> newer port installed version and not the older one.
> However, the port version doesn't have its own rc script. It usually
> uses the base version with ntpd_program and ntpd_config set.  With this
> latest change it means I have to have the base version installed again. 
> Is it possible to get the port version to have its own rc script?

net/openntpd has an rc script if you don't mind switching.  It is very
very simple to configure.

Ideally the original problem should be solved too but I ran into the
same problem with Kerberos.  I didn't get anywhere in the bug report
where I argued the system scripts still worked fine except for recent
changes in them causing a regression and failure with the port.  Both
situations could probably use a contributed patch to make an rc script.

More information about the freebsd-stable mailing list