diskless booting with 8.2 regression?

Gerrit Kühn gerrit at pmp.uni-hannover.de
Mon Jul 18 15:08:45 UTC 2011

On Mon, 18 Jul 2011 12:38:22 +0200 Gerrit Kühn
<gerrit at pmp.uni-hannover.de> wrote about diskless booting with 8.2

I guess I found the root of all evil now: device nodes on zfs!

This is how a linux /dev/console looked on the 8.0-FreeBSD server on

crw-------  1 root  wheel    5,   1 Oct 28	2010 /tank/diskless/gco-fe2/dev/console

Now, after updating to FreeBSD-8.2 and zfsv28 it looks like this on the server:

crw-r--r--  1 root  wheel  255, 0xffff00ff Jul 18 16:33 /tank/diskless/pt-fe2/dev/console

Strange enough, the Linux client still displays the correct values when using "ls -la", but it refuses to work properly.
I tried creating new device nodes from the client side with mknod and I tried getting correct ones from a backup, but they always end up being broken. Even movong the directories over to a ufs volume leaves them unusable:

crw-r--r--  1 root  wheel    0,   0 Jul 18 16:33 /tmp/console

Luckily, I am back into business now with my machines, because moving the stuff from zfs to ufs and dropping in a correct version of /dev on the ufs side works just fine.

However, it would be great if this could be fixed, because I do not have many ufs partitions left these days...


GK> Hi all,
GK> I just updated my nfs/tftp server for diskless booting from 8.0-rel to
GK> 8.2-stable. I have a bunch of Linux clients that used to work with the
GK> 8.0-setup, but fail to boot now.
GK> On the server side I see
GK> Jul 18 11:18:24 mclane tftpd[72434]: Got ERROR packet: TFTP Aborted
GK> in the log/messages, but the Linux kernel appears to be transferred
GK> over the net just fine (so this is probably not the real issue). It
GK> starts to boot and fails at some later point (with no apparent error
GK> message on screen) causing an endless reboot loop.
GK> I already googled for quite some time on this now, but nothing useful
GK> came up. The error message above seems to be harmless, at least the
GK> machines of people reporting them work nevertheless.
GK> Are there any known issues/regressions with tftp/nfs diskless booting?
GK> I read in some posts that people were vaguely "having problems" with
GK> it when updating to 8.2-something, but could not find any details. Are
GK> there any further hints what I could do to narrow down the problem?
GK> cu
GK>   Gerrit
GK> _______________________________________________
GK> freebsd-stable at freebsd.org mailing list
GK> http://lists.freebsd.org/mailman/listinfo/freebsd-stable
GK> To unsubscribe, send any mail to
GK> "freebsd-stable-unsubscribe at freebsd.org"

More information about the freebsd-stable mailing list