no USB mice detected on GA-MA74GM-S2

Michal Varga varga.michal at
Mon Apr 13 00:35:39 UTC 2009

2009/4/13  <piotr.smyrak at>:
>> ). A quick workaround is to attach your mouse (or any
>> other USB device that dies during boot - mices, keyboards,
>> card readers, etc. do this with FreeBSD 6/7's usb1 and
>> Gigabyte boards) -after- all USB drivers are loaded and
>> initialized. That always works.
> Unfortunately not in my case. I have tried this path before without
> success.
Are you sure you plugged the mouse out, then powered the computer on,
and plugged the mouse back in only after FreeBSD fully finished
booting? To make it perfectly redundantly safe, let's say, plugged
mouse in at the login prompt? Because I'm 100% positive (well, me and
everyone else with any recent Gigabyte board that I know) that
plugging the device in after the USB drivers are fully initialized
will prevent the lockup and port timeout, always.

>> Still, having it properly fixed in usb1 drivers wouldn't
>> hurt, of course,
> How do you go about that? I mean fixing a device in usb1.1.
Well, I guess that would need someone with both FreeBSD USB expertise
and some interest in fixing that bug (and probably an access to
particular Gigabyte hardware, though as it seems so far, anything
recent from Gigabyte and probably AMD6xx/7xx based will do it).
Anyway, I tried reporting it back then in 2007, all I got was a bunch
of arguments about power source fluctuations, carbon footprints,
Windows, PS/2 mices (for christ sake..), and well, being a lazy
coward, I gave up. Maybe you'll be luckier this time.


More information about the freebsd-stable mailing list