Upgrading from 7.0 to 7.1

Miroslav Lachman 000.fbsd at quip.cz
Wed Apr 1 03:03:29 PDT 2009


James Wu wrote:

> Hi all,
> 
> I'm brand new to the list so forgive me if this has been answered. I 
> tried searching the archives and tried googling and didn't come up with 
> any results.
> 
> I've been wanting to play with setfib multi-routing tables in 7.1, 
> however, we have a bunch of 7.0 machines. I thought I'd take a test 
> machine and upgrade it to 7.1. Everything went smoothly at first. I 
> compiled a custom 7.1 kernel and installed it just fine. Afterwards, I  
> ran:
> 
> freebsd-update fetch
> freebsd-update install
> to upgrade to the latest 7.0
> 
> then:
> freebsd-update upgrade -r 7.1-RELEASE
> freebsd-update install -r 7.1-RELEASE
> freebsd-update fetch
> to upgrade to 7.1

Did you just these 3 commands? You must use freebsd-update install 
twice. First time for kernel upgrade, then reboot and then 
freebsd-update install again to install new userland.
Do you have other binaries in /usr/sbin, /usr/bin, /bin /sbin upgraded? 
(ls -al shows newer date + time)

> now when I do a
> uname -a,
> I get FreeBSD 7.1-RELEASE-p3 which looks right to me

uname -a is derived from kernel, so it is possible that you have 7.1 
kernel with 7.0 userland.

> The problem I'm running into though is that the setfib binary doesn't 
> seem to been added during the upgrade as I don't see it anywhere. I took 
> a fresh install of 7.1 and do see it /usr/sbin/, but it's not there for 
> the upgraded version of 7.1.
> I guess at this point, I would like to do a reinstall of the sbin folder 
> if it is possible or somehow get a clean copy of the /usr/sbin/ folder 
> into my upgraded machine. Any hints on how to do that?

Miroslav Lachman


More information about the freebsd-stable mailing list