boot failed after make installkernel from 6.3-RELEASE to 7.0-RELEASE

Miroslav Lachman 000.fbsd at
Thu Sep 4 12:27:47 UTC 2008

Chih Liang wrote:

> Dear all,
> I've tried to upgrade my FreeBSD server from 6.3-RELEASE to 7.0-RELEASE, 
> but it is failed to boot after make kernel KERNCONF=GENERIC.
> I didn't modify any file at /usr/src/sys/i386/conf, it was all default.
> After done make kernel and reboot, system stop at:
>    Timecounters tick every 1.000 msec
>    ad0: 38166MB <Seagate ST340016A 3.75> at ata0-master UDMA100
> I can't boot in single mode, but I can boot in safe mode, and it showed:
>    Manual root filesystem specification:
>    <fstype>:<device> Mount <device> using filesystem <fstype>
>    eg. ufs:da0s1a
>    ? List valid disk boot devices
>    <empty line> Abort manual input
> I type "?" for list, but it only show acd0 and fdc0, "ufs:ad0s1a" or 
> "ufs:/dev/ad0s1a" are not working
> I can boot with /boot/kernel.old now (6.3-RELEASE), I rebuilt kernel 
> again and again, but still not work.
> I check the difference between old GENERIC on 6.3-RELEASE and new 
> GENERIC on 7.0-RELEASE, it has not difference besides new add in 
> 7.0-RELEASE.
> Is any one can help me? I don't want to reinstall...because I don't have 
> install cd...
> And sorry for my poor English, thank you for reading!

What is your hardware setup? (post dmesg)

I have bad experience with some old PC with nForce 2 chipset. This 
machine is unbootable with 7.x kernel, so I am using it with 6.3. (it 
can't boot even from 7.x CD)

Miroslav Lachman

More information about the freebsd-stable mailing list