boot failed after make installkernel from 6.3-RELEASE to 7.0-RELEASE

Chih Liang chih.liang at
Fri Sep 5 01:51:14 UTC 2008

Miroslav Lachman 提到:
> Chih Liang wrote:
>> Dear all,
>> I've tried to upgrade my FreeBSD server from 6.3-RELEASE to 
>> 7.0-RELEASE, but it is failed to boot after make kernel 
>> I didn't modify any file at /usr/src/sys/i386/conf, it was all default.
>> After done make kernel and reboot, system stop at:
>> Timecounters tick every 1.000 msec
>> ad0: 38166MB <Seagate ST340016A 3.75> at ata0-master UDMA100
>> I can't boot in single mode, but I can boot in safe mode, and it showed:
>> Manual root filesystem specification:
>> <fstype>:<device> Mount <device> using filesystem <fstype>
>> eg. ufs:da0s1a
>> ? List valid disk boot devices
>> <empty line> Abort manual input
>> I type "?" for list, but it only show acd0 and fdc0, "ufs:ad0s1a" or 
>> "ufs:/dev/ad0s1a" are not working
>> I can boot with /boot/kernel.old now (6.3-RELEASE), I rebuilt kernel 
>> again and again, but still not work.
>> I check the difference between old GENERIC on 6.3-RELEASE and new 
>> GENERIC on 7.0-RELEASE, it has not difference besides new add in 
>> 7.0-RELEASE.
>> Is any one can help me? I don't want to reinstall...because I don't 
>> have install cd...
>> And sorry for my poor English, thank you for reading!
> What is your hardware setup? (post dmesg)
> I have bad experience with some old PC with nForce 2 chipset. This 
> machine is unbootable with 7.x kernel, so I am using it with 6.3. (it 
> can't boot even from 7.x CD)
> Miroslav Lachman
Here is my /var/run/dmesg.boot:

Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.3-RELEASE-p3 #0: Wed Sep 3 15:58:00 CST 2008
root at daxiongb:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) Processor (801.83-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x631 Stepping = 1
AMD Features=0xc0440800<SYSCALL,<b18>,MMX+,3DNow!+,3DNow!>
real memory = 335478784 (319 MB)
avail memory = 318791680 (304 MB)
kbd1 at kbdmux0
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
hptrr: HPT RocketRAID controller driver v1.1 (Sep 3 2008 15:57:08)
acpi0: <AMIINT > on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 82C8363 (Apollo KT133x/KM133) host to PCI bridge> mem 
0xe0000000-0xe0ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 82C686A UDMA66 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 7.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
uhci0: <VIA 83C572 USB controller> port 0xd400-0xd41f irq 12 at device 
7.2 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xd800-0xd81f irq 12 at device 
7.3 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pci0: <serial bus, SMBus> at device 7.4 (no driver attached)
rl0: <RealTek 8139 10/100BaseTX> port 0xd000-0xd0ff mem 
0xdfffff00-0xdfffffff irq 9 at device 13.0 on pci0
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:40:c7:81:90:ca
pci0: <multimedia, audio> at device 14.0 (no driver attached)
acpi_button1: <Sleep Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
fdc0: <floppy drive controller> port 0x3f2-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on 
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 drq 
3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xc0000-0xc7fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 801825289 Hz quality 800
Timecounters tick every 1.000 msec
hptrr: no controller detected.
ad0: 39266MB <IC35L040AVVN07 0 VA2OAG0A> at ata0-master UDMA66
acd0: CDRW <LITE-ON LTR-48246S/SS0E> at ata1-slave UDMA33
Trying to mount root from ufs:/dev/ad0s1a
rl0: link state changed to UP

Is it the VIA chipset?

More information about the freebsd-stable mailing list