boot failed after make installkernel from 6.3-RELEASE to 7.0-RELEASE

Chih Liang chih.liang at
Fri Sep 5 01:42:16 UTC 2008

Bartosz Stec wrote:
> Chih Liang pisze:
>> Dear all,
>> I've tried to upgrade my FreeBSD server from 6.3-RELEASE to 
>> 7.0-RELEASE, but it is failed to boot after make kernel 
>> I didn't modify any file at /usr/src/sys/i386/conf, it was all default.
>> After done make kernel and reboot, system stop at:
>>    Timecounters tick every 1.000 msec
>>    ad0: 38166MB <Seagate ST340016A 3.75> at ata0-master UDMA100
>> I can't boot in single mode, but I can boot in safe mode, and it showed:
>>    Manual root filesystem specification:
>>    <fstype>:<device> Mount <device> using filesystem <fstype>
>>    eg. ufs:da0s1a
>>    ? List valid disk boot devices
>>    <empty line> Abort manual input
>> I type "?" for list, but it only show acd0 and fdc0, "ufs:ad0s1a" or 
>> "ufs:/dev/ad0s1a" are not working
>> I can boot with /boot/kernel.old now (6.3-RELEASE), I rebuilt kernel 
>> again and again, but still not work.
>> I check the difference between old GENERIC on 6.3-RELEASE and new 
>> GENERIC on 7.0-RELEASE, it has not difference besides new add in 
>> 7.0-RELEASE.
>> Is any one can help me? I don't want to reinstall...because I don't 
>> have install cd...
>> And sorry for my poor English, thank you for reading!
>> Regards,
>> Chih Liang
>> _______________________________________________
>> freebsd-stable at mailing list
>> To unsubscribe, send any mail to 
>> "freebsd-stable-unsubscribe at"
> Did you make buildworld before buildkernel? If not, boot kernel.old 
> ane follow these rules:
> 1. csup 7-stable sources (just to be sure)
> 2. rm -fR /usr/obj (just to be sure again)
> 3. make buildworld && make buildkernel KERNCONF=GENERIC
> 4. make installkernel
> 5. reboot in single user mode
> 6. mergemaster -p
> 7. make installworld
> 8. mergemaster
> 9. make delete-old
> 10. make delete-old-libs
> Good luck!
Yes I did.
I tried to update source to 7.1, but it failed with the same problem, 
then I thought it is the bug at -STABLE. And I remove entire /usr/src 
and /usr/obj and update source to 7.0 again, but  still failed when I 
boot after make buildworld and make kernel.

More information about the freebsd-stable mailing list