Nagios + 6.3-RELEASE == Hung Process

Tom Judge tom at tomjudge.com
Wed Jan 2 15:17:09 PST 2008


Jarrod Sayers wrote:
> On 03/01/2008, at 1:56 AM, Tom Judge wrote:
>> I have also seen this issue, but have always put it down to the way that
>> we manage our nagios deployments with cfengine.  I will try to deploy
>> this change and monitor for the problem to see if it persists.
> 
> I hope I can confirm your frustrations.  There is a threading issue with 
> Nagios when it's binaries are linked against libpthread(3) threading 
> library, the default on recent FreeBSD 5.x releases and all 6.x 
> releases. The issue is random and extremely difficult to track down with 
> the symptoms being a second Nagios process sitting on the system hanging 
> a CPU.  Be rest assured that I have been working on it, and have seen it 
> on one system of mine.
> 

Not sure if this is related at all but out of the 3 nagios deployments 
we have here I have only ever seen it on one (It currently has 2 nagios 
threads spinning CPU time atm).

The differences on that server are:

	* It is amd64 compared to i386
	* It also runs ndo2db from ndoutils 1.4b7

All the systems run 6.2-RELEASE-p5 and nagios-2.9_1, they are also all 
patched with gnu libltdl patch below.

Don't know if that info is of any use to you.

> Changes have been submitted for net-mgmt/nagios-devel (aka Nagios 
> 3.0.r1)) to force the build process to link against libthr(3) where 
> available, removing the need to map libpthread() out with 
> /etc/libmap.conf.  If this goes well, as stated in the PR, i'll 
> back-port it to net-mgmt/nagios (aka Nagios 2.10) in the next few days.
> 
> If anyone out there is running net-mgmt/nagios-devel and feels like 
> trying it for me, see ports/119246 and drop me an email with a before 
> and after "ldd /usr/local/bin/nagios".
> 
>> On a side note if you want to use broker modules with nagios from port
>> you need to change the following in the port Makefile in order to make
>> them load properly:
>>
>> From:
>> USE_AUTOTOOLS=  autoconf:259
>> To:
>> SE_AUTOTOOLS=  autoconf:259 libltdl:15
>>
>> I sent an email to the maintainer but got no response and my email did
>> not seem to have affected the last commit to upgrade to 2.10
> 
> I did receive that email and the changes went in with the last commit of 
> net-mgmt/nagios-devel to test.  No issues have arisen so i'll be 
> back-porting it to net-mgmt/nagios soon for you.  There also has been a 
> rather large ports freeze which delayed the upgrade to Nagios 2.10, that 
> PR was submitted on the 1st of November and committed on the 13th of 
> December.  Unfortunately your email fell somewhere in the middle, 
> apologies for not letting you know.
> 

Thanks for this,  I currently maintain the patch on our build servers.



More information about the freebsd-stable mailing list