Audio CD problem on laptop VGN-SZ61MN

Carlos A. M. dos Santos unixmania at
Sat Aug 9 00:17:42 UTC 2008

On Fri, Aug 8, 2008 at 5:13 AM, Harald Weis <hawei at> wrote:
> Is there anyone out there who has installed FreeBSD on the above Sony
> laptop ?
> Both ''cat filename > /dev/dsp0.0'' or ''vlc cdda:///dev/acd0@1 are OK.
> If I run ''cdcontrol -f /dev/acd0 play'', there is no sound.
> But the output of ''cdcontrol -f /dev/acd0 status audio'' is alright.
> (same behaviour for cd0 instead of acd0)
> And the output of ''mplayer cdda://1//dev/acd0'' is:
> Playing cdda://1//dev/acd0.
> ++ WARN: open: Inappropriate ioctl for device
> **ERROR: fread (): Invalid argument
> On the other hand, DVD's play fine, for example with
> either ''vlc dvd:///dev/acd0@2'' or ''mplayer dvd://2''
> I wonder whether the problem is related to the FAILURE line in dmesg:
> acd0: DVDR <MATSHITADVD-RAM UJ-852S/1.01> at ata0-master UDMA33
> acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
> acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
> cd0 at ata0 bus 0 target 0 lun 0
> cd0: <MATSHITA DVD-RAM UJ-852S 1.01> Removable CD-ROM SCSI-0 device
> cd0: 33.000MB/s transfers
> cd0: Attempt to query device size failed: NOT READY, Medium not present
> Adding ''device atapicam'' in the kernel doesn't make a difference.
> I found some messages concerning the FAILURE line in the mailing list
> archives, but no solution.

Same result on my notebook (HP nx6320) and this is not a surprise. The
"mixer" command does not show a "cd" input, meaning that there is no
input port for the analog audio output of the CD drive (if any). The
"status audio" arguments instructs cdcontrol to inquire the drive, not
the audio device.

NetBSD's "cdplay" supports digital transfer mode since version 4.0.
Perhaps this feature could be implemented on cdcontrol.

If you think things can't get worse it's probably only
because you lack sufficient imagination.

More information about the freebsd-stable mailing list