Audio CD problem on laptop VGN-SZ61MN

Oliver Fromme olli at
Fri Aug 8 17:46:55 UTC 2008

Harald Weis wrote:
 > Both ''cat filename > /dev/dsp0.0'' or ''vlc cdda:///dev/acd0@1 are OK.
 > If I run ''cdcontrol -f /dev/acd0 play'', there is no sound.
 > But the output of ''cdcontrol -f /dev/acd0 status audio'' is alright.
 > (same behaviour for cd0 instead of acd0) 

Are you sure your mixer settings are OK?
What's the output from /usr/sbin/mixer?

Note that normal audio playback from software such as
cat, vlc and mplayer go through the "pcm" channel of
the mixer, while the direct CD playback (as initiated
by cdcontrol) goes through the "cd" channel of the

So please make sure that your "cd" channel isn't set
to zero.  Sometimes the channels are wired incorrectly
in the hardware so it ends up a different channel --
If in doubt, just crank all the channels up to non-zero

 > And the output of ''mplayer cdda://1//dev/acd0'' is:
 > Playing cdda://1//dev/acd0.

Are you sure this is the right syntax for mplayer?
Normally I don't use mplayer for audio CDs, but I
think when I tried it the syntax cd://1 or similar
worked fine.  You might need to have a symlink
/dev/cd -> /dev/acd0c for that to work.  At least
I needed it back then.

Best regards

Oliver Fromme, secnetix GmbH & Co. KG, Marktplatz 29, 85567 Grafing b. M.
Handelsregister: Registergericht Muenchen, HRA 74606,  Geschäftsfuehrung:
secnetix Verwaltungsgesellsch. mbH, Handelsregister: Registergericht Mün-
chen, HRB 125758,  Geschäftsführer: Maik Bachmann, Olaf Erb, Ralf Gebhart

FreeBSD-Dienstleistungen, -Produkte und mehr:

"And believe me, as a C++ programmer, I don't hesitate to question
the decisions of language designers.  After a decent amount of C++
exposure, Python's flaws seem ridiculously small." -- Ville Vainio

More information about the freebsd-stable mailing list