grep: memory exhausted

van Osnabrugge, Sean svanosnabrugge at
Wed Nov 29 12:10:55 PST 2006

Hi there,


I am running a fresh install of FreeBSD-6.1-Stable as a guest OS in
VMWare 1.0.1 with 1 GB of RAM.


Whenever I try to grep a large text file (400 MB+), grep terminates with
"grep: memory exhausted"


I have tried piping grep (cat "file" | grep "search term")

I have tried it with -line-buffered


ulimit -a show:

core file size        (blocks, -c) unlimited

data seg size         (kbytes, -d) 524288

file size             (blocks, -f) unlimited

max locked memory     (kbytes, -l) unlimited

max memory size       (kbytes, -m) unlimited

open files                    (-n) 11095

pipe size          (512 bytes, -p) 1

stack size            (kbytes, -s) 65536

cpu time             (seconds, -t) unlimited

max user processes            (-u) 5547

virtual memory        (kbytes, -v) unlimited


Any help?






This e-mail message is privileged, confidential and subject to copyright. 
Any unauthorized use or disclosure is prohibited.

Le contenu du pr'esent courriel est privil'egi'e, confidentiel et soumis `a 
des droits d'auteur. Il est interdit de l'utiliser ou de le divulguer 
sans autorisation.


More information about the freebsd-stable mailing list