Problems unmounting/fssyncking extern UFS filesystem

Ronald Klop ronald-freebsd8 at
Mon Nov 27 16:15:42 PST 2006

On Mon, 27 Nov 2006 21:19:40 +0100, Matthew D. Fuller  
<fullermd at> wrote:

> On Tue, Nov 28, 2006 at 05:37:58AM +1100 I heard the voice of
> Peter Jeremy, and lo! it spake thus:
>> All current Un*x filesystems will automatically flush all buffers as
>> part of the unmount process
> That Depends(tm), partly on what you mean by 'unmount'.
> With my Nov05 and Jun06 -CURRENT's, I had to take great care to sync
> and sync and wait and sync and sync filesystems before "mount -u -o
> ro"'ing them, because otherwise they'd end up NOT flushing everything,
> leaving unreferenced stuff around that fsck had to clean up, but only
> if I ran it manually because mount DID mark the filesystem as clean.
> I just tried to reproduce it on my last-week -CURRENT, and it no
> longer does that.  Instead, it locked itself into a "softdep_waitidle:
> Failed to flush worklist" loop and won't LET me remount r/o (or
> unmount) the filesystems.  Obviously, I should have kept up my
> now-established habit of sync'ing and waiting a while before
> un/remounting...

IMHO: Please discuss this on freebsd-current at And read the  
handbook ( about  
releases/versions/branches. -CURRENT is known to have bugs.

  Ronald Klop
  Amsterdam, The Netherlands

More information about the freebsd-stable mailing list