Problems unmounting/fssyncking extern UFS filesystem

Matthew D. Fuller fullermd at
Mon Nov 27 12:37:48 PST 2006

On Tue, Nov 28, 2006 at 05:37:58AM +1100 I heard the voice of
Peter Jeremy, and lo! it spake thus:
> All current Un*x filesystems will automatically flush all buffers as
> part of the unmount process

That Depends(tm), partly on what you mean by 'unmount'.

With my Nov05 and Jun06 -CURRENT's, I had to take great care to sync
and sync and wait and sync and sync filesystems before "mount -u -o
ro"'ing them, because otherwise they'd end up NOT flushing everything,
leaving unreferenced stuff around that fsck had to clean up, but only
if I ran it manually because mount DID mark the filesystem as clean.

I just tried to reproduce it on my last-week -CURRENT, and it no
longer does that.  Instead, it locked itself into a "softdep_waitidle:
Failed to flush worklist" loop and won't LET me remount r/o (or
unmount) the filesystems.  Obviously, I should have kept up my
now-established habit of sync'ing and waiting a while before

Matthew Fuller     (MF4839)   |  fullermd at
Systems/Network Administrator |
           On the Internet, nobody can hear you scream.

More information about the freebsd-stable mailing list