adaptec utilities on amd64?

Bruce Burden brucegb at
Wed Nov 15 16:35:01 PST 2006

On Wed, Nov 15, 2006 at 05:14:18PM -0500, Vivek Khera wrote:
> Does anyone have any hints on monitoring adaptec RAID's (particularly  
> aac devices such as 2230SLP) on FreeBSD 6.2/amd64?  I don't need to  
> reconfigure anything, just know when and which drives have failed, if  
> any.
	I have a 2230SLP that I will be installing early next week
   on my AMD64 implementation. I am hoping that the aaccli program
   in ports will work.
> I installed (with some $ARCH trickery) the linux-afaapps port, but it  
> fails to run with this error:
> /compat/linux/usr/sbin/afacli: error while loading shared libraries: / 
> usr/lib/ ELF file OS ABI invalid
	Did you brandelf the library? I tried working with the code
   from the CD, but ran into three problems:

1) I could not get additional .jar files recognised. (for the 
       authenticateUser code)

2) The java code eventually goes into linux shared libraries, and
  (native) java seems rather reluctant to use linux libraries in
  the compat mode

3) Linux mode java should have worked based on the pathname supplied,
  but it did not. So, back to the aaccli program...
> So then I tried the linux arcconf utility on the CD that came with  
> the card.  It reports "Controllers found: 0".
	Yeah, me to. But, I figure that is because it runs into
   other problems first.

  "I like bad!"                         Bruce Burden    Austin, TX.
        - Thuganlitha
        The Power and the Prophet
        Robert Don Hughes

More information about the freebsd-stable mailing list