adaptec utilities on amd64?

Vivek Khera vivek at
Wed Nov 15 14:14:49 PST 2006

Does anyone have any hints on monitoring adaptec RAID's (particularly  
aac devices such as 2230SLP) on FreeBSD 6.2/amd64?  I don't need to  
reconfigure anything, just know when and which drives have failed, if  

The latest card I got apparently has firmware too new for use with  
the FreeBSD native aaccli.  Older versions of that card worked fine  
when freebsd4 compat was built into the kernel with FreeBSD 6.0, 6.1  
and 6.2.

I installed (with some $ARCH trickery) the linux-afaapps port, but it  
fails to run with this error:

/compat/linux/usr/sbin/afacli: error while loading shared libraries: / 
usr/lib/ ELF file OS ABI invalid

So then I tried the linux arcconf utility on the CD that came with  
the card.  It reports "Controllers found: 0".

Is there any other program to try?   Has anyone hacked up a small  
program to do the necessary ioctl calls to the aac driver to probe  
the raid status and print out a degraded/optimal type output?   
something like what the kernel prints on boot would be sufficient.

I'm very scared to put the server into production without a way to  
monitor the RAID status.

More information about the freebsd-stable mailing list