Cannot boot 6.1-PRERELEASE in SMP mode

Pete French petefrench at
Tue Mar 14 12:41:17 UTC 2006

I have an MSI K8D Master, wth an Opteron 242 installed, on which I have been
happily running 6.0-RELEASE. I did have one problem wuth the board, which was
that if I had ACPI enabled then the operating system would not boot, it froze
at the point where it waited for the SCSI devices to settle. I got round this
by disabling ACPI in loader.conf and it works fine.

A couple of days ago I installed a second Opteron 242 in the other socket to
build an SMP machine. The second processor is recognised by the BIOS - and I
have also moved half the memory to be attached to the second processor. The
BIOS still shows 1GB so I am pretty confident the 2nd processor works. Swapping
the processors also works, so I know the chips are good.

But FreeBSD will not boot SMP with the second processor installed. It behaves
exactly as it did with a single processor and ACPI enabled - i.e. it stops
at the 'Waiting for SCSI devices to settle" point and does not get beyond

I have two SCSI controllers installed - a Compaq 5304 RAID controller and
an Adaptec 29160. The system boots from the Adaptec. I do have ATAPICAM
compiled in to the kernel, but I get the same result with generic SMP.

I have upgraded the machine to 6.1-PRERELEASE and I still get the same problem.
Does anybody have any ideas about setting about debugging this ? The
motherboard has been flashed to the latest BIOS and I am running i386 not
amd64 on the board.



More information about the freebsd-stable mailing list