5.4 install disc1 will not find hard drive

Ted Mittelstaedt tedm at toybox.placo.com
Sat May 14 21:38:31 PDT 2005

> -----Original Message-----
> From: owner-freebsd-questions at freebsd.org
> [mailto:owner-freebsd-questions at freebsd.org]On Behalf Of fbsd_user
> Sent: Saturday, May 14, 2005 12:54 PM
> To: freebsd-questions at FreeBSD. ORG
> Cc: stable at freebsd.org
> Subject: 5.4 install disc1 will not find hard drive

> Power management and APIC have been bios disabled since
> version FreeBSD 3.4
> version so that is not the problem. I tried selecting safe
> option to boot
> and still get same error 'no hard disk found".   My hard drive
> is an western
> digital 310100 on ata0 as master. When using this 5.4 install
> cd on other
> pc/ motherboard/ hard drive combos I get same error.
> I think there is something wrong with the build process of the
> disc1.iso
> file.

I don't think there is anything wrong with the build process of
disc1.iso.  I think instead that someone made a change in the atapi
driver that broke this.

I have a Intel Desktop Motherboard VC820 that this exact thing happened
to.  In my case, I fortunately was running a Hipoint RAID card in it so
the only thing that got wacked was the system now does not recognize
that there is a CDROM on the secondary onboard IDE controller.  Last
week I had it running FreeBSD 4.11 just fine.  (not on the RAID

I had assumed that using the RAID controller made it so that the onboard
ATAPI controller had some problem, but after seeing this post it is clear
that they broke the driver.

DO you want to file a PR or should I?


More information about the freebsd-stable mailing list