5.4 install disc1 will not find hard drive

fbsd_user fbsd_user at a1poweruser.com
Sun May 15 04:41:01 PDT 2005

> -----Original Message-----
> From: owner-freebsd-questions at freebsd.org
> [mailto:owner-freebsd-questions at freebsd.org]On Behalf Of fbsd_user
> Sent: Saturday, May 14, 2005 12:54 PM
> To: freebsd-questions at FreeBSD. ORG
> Cc: stable at freebsd.org
> Subject: 5.4 install disc1 will not find hard drive

> Power management and APIC have been bios disabled since
> version FreeBSD 3.4
> version so that is not the problem. I tried selecting safe
> option to boot
> and still get same error 'no hard disk found".   My hard drive
> is an western
> digital 310100 on ata0 as master. When using this 5.4 install
> cd on other
> pc/ motherboard/ hard drive combos I get same error.
> I think there is something wrong with the build process of the
> disc1.iso
> file.

I don't think there is anything wrong with the build process of
disc1.iso.  I think instead that someone made a change in the atapi
driver that broke this.

I have a Intel Desktop Motherboard VC820 that this exact thing
to.  In my case, I fortunately was running a Hipoint RAID card in it
the only thing that got wacked was the system now does not recognize
that there is a CDROM on the secondary onboard IDE controller.  Last
week I had it running FreeBSD 4.11 just fine.  (not on the RAID

I had assumed that using the RAID controller made it so that the
ATAPI controller had some problem, but after seeing this post it is
that they broke the driver.

DO you want to file a PR or should I?


-----Original Message-----
From: Ted Mittelstaedt [mailto:tedm at toybox.placo.com]
Sent: Sunday, May 15, 2005 12:38 AM
To: fbsd_user at a1poweruser.com; freebsd-questions at FreeBSD. ORG
Cc: stable at freebsd.org
Subject: RE: 5.4 install disc1 will not find hard drive


I filed a PR on the missing miniinst.iso file.

And it's not been addressed yet.  So if you have some pull
in getting PR's worked on then you should file the PR on this
As I see this, it's a show stopper in distributing 5.4 stable and
to be addressed immediately because all the mirror FTP sites are
populated with non-functional disc1 iso files.

Here are some more details from the boot of disc1.

The btx loader issues this messages
bios drive C: is disk1

and near the end of the boot messages I get

ata1-master: pio=0x0c wdma=0x22 udma=0x42 cable=40pin
ata1-master; setting pio4 on VIA 82C596B chip

Please send me the PR number after you report this so I can track


More information about the freebsd-stable mailing list