Problem with DHCLIENT vs 64-bit time_t

matt matt at
Mon Feb 16 18:38:47 PST 2004

I hate to add to the problems instead of proposing solutions, but I
noticed that /etc/periodic/weekly/310.locate seems to be broken after the
64 bit time_t switch.

I'll run another buildworld out of the 64 bit time_t system I have up with
cvsup'd sources, see what happens...  I haven't had any problems starting
dhclient, works fine other than the fact that it absorbs considerable
system resources.


On Mon, 16 Feb 2004, Garance A Drosihn wrote:

> At 5:13 PM -0600 2/15/04, matt wrote:
> >
> >  Anyhow, here is the strangeness.  After compiling/installing
> >  the 64 bit time_t world/kernel, I'm getting some serious lag
> >  on this machine.  When logged in via ssh, the shell freezes
> >  every few seconds for a brief period of time.  ...
> And in a later message, he wrote:
> >  Killing dhclient brought things back to normal - and yes, I
> >  did remove /var/db/dhcp.leases (had to, dhclient wouldn't
> >  work until I did).  My kernel was just a run of the mill
> >  GENERIC, no changes.
> Well, there does seem to be some kind of problem here, but I
> don't know what to do about it just yet.  In my earlier testing,
> I did do some testing with a dhcp-configured machine, but not a
> lot of it.
> After reading the above report, I took my system which was already
> upgraded to 64-bTT, and which also already has all of it's ports
> recompiled for 64-bTT.  I cvsup'ed the base system, and did a
> complete new buildworld/installworld cycle with 64-bTT.  So, it
> is a system which has successfully gone through two consecutive
> 64-bTT builds without error.  I have not run into any other
> problems with this upgraded system.
> I tried configuring it for DHCP, rebooted it, and the startup
> hung at the point of starting dhclient.  I ctrl-c'ed out of
> the hang.  Once the system was up, I tried running dhclient
> again.  Again it hung.  In my case it's hanging before it gets
> any information (hme0 is not configured at all).  I assume
> that in Matt's case, it did get some dhcp address, because he
> said he was ssh'ed into it.  This testing reminded me that
> dhclient did sometimes hang on me in my earlier testing, but
> I forgot about that when I had some reboots where it worked.
> That's about as much as I know about the problem so far.  Does
> anyone have some time to look into this?
> --
> Garance Alistair Drosehn            =   gad at
> Senior Systems Programmer           or  gad at
> Rensselaer Polytechnic Institute    or  drosih at

More information about the freebsd-sparc64 mailing list