Getting X on an Ultra 10

Will Andrews will at
Mon Oct 27 08:37:54 PST 2003

On Mon, Oct 27, 2003 at 11:22:20AM -0500, Brian Johnson wrote:
> My name is Brian Johnson and I'm new to both FreeBSD and this list.  I
> hope I'm in the right place.

You are.

> Before I begin, I'd like to say I've tried my best to find the answer on
> my own, with no luck.  If I'm asking something already answered, my
> apologies.

The mailing list archives for sparc64@ have the answer.  In fact
this very question was asked a few days ago.

> The hardware I'm trying this on is a stock Ultra 10.  I downloaded the
> miniinstall disk for FreeBSD 5.1 and tried to install.  Once I figured out
> how to navigate the menus, I selected a "Standard" install.  On the next
> page, I selected all of the distributions (choices 2-9, IIRC).  On the
> next screen I told it to do an FTP install.  It does its thing for a
> while.  Then, I begin seeing error messages.  I believe the exact message
> was "Package XFree86-FontServer not found in INDEX".  There were two or
> three more XFree86 messages like that one.  Then I got another one that
> said "Package wrapper not found in INDEX".  I clicked OK and let the
> install continue.

Yes.. the issue is that syscons isn't supported and without it
XFree86 will not work properly.  Even in 5.1-CURRENT this hasn't
been resolved.  Also I believe there are some bugs with the
creator video driver.

Jake has some patches that he said he was going to commit to
-current soon, so maybe 5.2 will support your U10.


More information about the freebsd-sparc64 mailing list