PicoBSD on FreeBSD 5.1-CURRENT

Hartmann, O. ohartman at klima.physik.uni-mainz.de
Thu Jul 17 06:38:45 PDT 2003


We utilize now a bunch of FreeBSD 5.1-CURRENT servers and workstations
around here and at the moment one of our firewalls is still running
with FreeBSD 4.7-p7.
I would like to upgrade to FreeBSD 5.1-CURRENT within the PicoBSD environment,
but I run into trouble with several userland programs.

I changed the kernel configuration scheme towards the new FBSD 5.X standard
and this seems to work well.

disklabel is now bsdlabel (but there is a hardlink) and the syntax has
changed. I tried to correct this, but bsdlabel has still a problem when
labeling /dev/md1. This is a result due to my insufficient knowledge how to
build a picobsd.

newfs does not have the '-p' option any more. I corrected this and the
'picobsd' script works well until it tries to 'bsdlabel' the image, then
I receive this error:


*** Copy generic floppy_tree into MFS...

*** Fixing permissions

*** create_mfs() Preparing MFS filesystem...

*** free_vnode() md1

*** init_fs_image() /usr/src/release/picobsd/build_dir-bastion/fs.PICOBSD 4096

*** Labeling MFS image

*** Filesystem 1K-blocks Used Avail Capacity  Mounted on
/dev/md1c       3831    0  3831     0%    /var/tmp/picobsd.eWOKdceTDT

*** Copy mfs tree into file

*** Status of mfs image
Filesystem 1K-blocks Used Avail Capacity iused ifree %iused  Mounted on
/dev/md1c       3831 1490  2341    39%      81   493   14%   /var/tmp/picobsd.eWOKdceTDT
/dev/md1c: clean, 4682 free (18 frags, 583 blocks, 0.2% fragmentation)

*** free_vnode() md1

*** fill_floppy_image()

*** Preparing 2880kB floppy filesystem...

*** init_fs_image() /usr/src/release/picobsd/build_dir-bastion/picobsd.bin 2880

*** Labeling floppy image
bsdlabel: /dev/md1: no valid label found
---> fail: Error <1> error code <floppy_disklabel> in <>
Error while doing disklabel on of floppy.img size 2880
---> Aborting /usr/src/release/picobsd/build/picobsd.neu

*** final_cleanup()

*** free_vnode() md1


My new picobsd-script is named 'picobsd.neu'. I changed the following lines to come
alongside the changes made in 5.X:

    # create a disklabel ...
    #bsdlabel -Brw -b ${c_boot1} -s ${b2} ${l_vndev} auto || \
    #   fail $?  floppy_disklabel
    ls -la /dev/md*
    bsdlabel -B -b ${c_boot1} ${l_vndev} auto || \
        fail $?  floppy_disklabel

${c_boot1} targets /boot/cdboot, newfs has no -p option.

If anyone has a hint or tip, please email me.

Thanks a lot,

O. Hartmann

ohartman at mail.physik.uni-mainz.de
Systemadministration des Institutes fuer Physik der Atmosphaere (IPA)
Johannes Gutenberg Universitaet Mainz
Becherweg 21
55099 Mainz

Tel: +496131/3924662 (Maschinenraum)
Tel: +496131/3924144 (Buero)
FAX: +496131/3923532

More information about the freebsd-small mailing list