Ruby Gem Require LoadError (8-STABLE, Ruby 1.9.1)

Aaron Gifford astounding at
Thu Jan 28 21:26:48 UTC 2010

2010/1/28 Stanislav Sedov <stas at> responded:
> I suspect that you installed gems for ruby 1.8, not ruby 1.9.  Can you show
> the output of gem19 list?

On the system in question gem is a symlink to gem19 (ruby version 1.8
is NOT installed on the system.), so the "gem list" shown in my
original post is the output of gem19.

> Also, for ruby19 you should not use 'require "rubygems"', just use plain require.

Heh, yes, old habits are hard to break. I keep that unnecessary
require around because much of my stuff has to be both 1.8 and 1.9
compatible. :)

Aaron out.

More information about the freebsd-ruby mailing list