Ruby Gem Require LoadError (8-STABLE, Ruby 1.9.1)
stas at FreeBSD.org
Thu Jan 28 20:07:51 UTC 2010
On Thu, 28 Jan 2010 12:33:34 -0700
Aaron Gifford <astounding at gmail.com> mentioned:
> I'm running a fresh install of FreeBSD 8-STABLE (installed then
> updated to STABLE as of 27 Jan. 2010). All ports are freshly built
> and installed.
> THE PROBLEM:
> After installing Ruby 1.9.1 and several gems via the Ports collection,
> ruby scripts that use the gems fail to load:
I suspect that you installed gems for ruby 1.8, not ruby 1.9. Can you show
the output of gem19 list?
Also, for ruby19 you should not use 'require "rubygems"', just use plain require.
More information about the freebsd-ruby