Ruby Gem Require LoadError (8-STABLE, Ruby 1.9.1)

Stanislav Sedov stas at
Thu Jan 28 22:31:28 UTC 2010

On Thu, 28 Jan 2010 14:26:46 -0700
Aaron Gifford <astounding at> mentioned:

> 2010/1/28 Stanislav Sedov <stas at> responded:
> > I suspect that you installed gems for ruby 1.8, not ruby 1.9.  Can you show
> > the output of gem19 list?
> On the system in question gem is a symlink to gem19 (ruby version 1.8
> is NOT installed on the system.), so the "gem list" shown in my
> original post is the output of gem19.

Oh, so you have ruby 1.9 as a default version?

> >
> > Also, for ruby19 you should not use 'require "rubygems"', just use plain require.
> Heh, yes, old habits are hard to break. I keep that unnecessary
> require around because much of my stuff has to be both 1.8 and 1.9
> compatible. :)

Weird, it should work with 'require "rubygems"' as well.
I'll try to check at the evening.
Maybe something got broken after the last update.

Stanislav Sedov

More information about the freebsd-ruby mailing list