script problem

Antonio Olivares olivares14031 at
Wed Apr 21 23:56:32 UTC 2021

On Wednesday, April 21, 2021, Norman Gray <norman.gray at> wrote:
> Antonio, hello.
> On 21 Apr 2021, at 22:08, Antonio Olivares wrote:
>> I have made changes from #!/bin/bash to #!/bin/sh and added some code
>> so that the files and are skipped from being
>> metaposted.  These files are not in texlive2021 for some reason or
>> another and I do not know how to add them as easily if I were using
>> miktex install on the fly option.
> It looks like the m3D package [1], where those files from from, is a
little old, and may not be compatible with the current version of mpost.
That may be why it's not readily available as part of a current TeXLive.
Certainly, when I try (just now) to build this book from the sources, and
install m3D locally, the build of fails with an error which smells
to me strongly of version-skew.
> If I press on, I see that the source depends on a picins.sty package,
which appears [2] to be a LaTeX 2.09 package (ie, _very_ old).
> I suspect it would be challenging to build the book from its sources,
using a half-way recent release of TeXLive.  It doesn't look impossible,
but it might well involve some non-trivial hacking of the source, which it
might be better to encourage the author to embark on.
> Good luck!
> Norman
> [1]
> [2]
> --
> Norman Gray  :
> SUPA School of Physics and Astronomy, University of Glasgow, UK

Dear Sir

The book gets created, but the file fails to build.  The m3D
files, I have put the files m3D* on the same directory and the picins.sty.
The question is how the metapost files get processed by the script.
Something changed because the script did run the metapost files and got
their output and them latex'd the source files and it worked in FreeBSD 12
but not in FreeBSD 13.  I do not know what causes this?

I had to
$ for i in *.mp ; TEX=latex mpost "$i": done;

Otherwise I get message that many files missing.  This part worked before
and now it does not.

I want to metapost the files except the m3D* files, it worked in previous
versions but not new version.

Thank you for helping.

Best Regards,


More information about the freebsd-questions mailing list