Fwd: Dell XPS 8940 SATA and NVMe disk controller not recognized

Eugene Grosbein eugen at grosbein.net
Sat Apr 3 23:20:48 UTC 2021

04.04.2021 5:09, Karl Dunn wrote:

>> See if the BIOS offers a choice of configuring the controller as SATA instead of RAID. That worked for me on an Inspiron 1180. (It also made W10 unbootable - apparently each OS occupies its own universe.)
> That worked, precisely as it did for you: gpart list shows partitions and drives much to my expectations, and Win10 no longer boots.  I can boot windows by setting the BIOS config back to RAID.  That's not much of a pain.  Now to try installing 12.2-RELEASE on the SSD!
> Thank you very much indeed!

When such host-based RAID/AHCI system came in times of Windows XP, there was a way to make it boot Windows
with both kinds of BIOS settings. Boot to Windows in a way it normally boots - RAID in your case -
and forcibly add a driver corresponding to PCI ids of the controller in ACHI mode,
so Windows kernel already has it at boot time.

More information about the freebsd-questions mailing list