Fwd: Dell XPS 8940 SATA and NVMe disk controller not recognized

Karl Dunn kldunn at hiwaay.net
Sat Apr 3 22:09:45 UTC 2021

-------- Forwarded Message --------
Subject: Re: Dell XPS 8940 SATA and NVMe disk controller not recognized
Date: Sat, 3 Apr 2021 17:05:59 -0500
From: Karl Dunn <kldunn at hiwaay.net>
To: Barney Wolff <barney at databus.com>

On 4/3/2021 2:37 PM, Barney Wolff wrote:
> On Sat, Apr 03, 2021 at 02:25:30PM -0500, Karl Dunn wrote:
>> I have new Dell XPS 8940 that came with Windows 10 Home installed.  I have
>> created two partitions for FreeBSD, one on its NMVe 256GB SSD, and one on
>> its WD 1TB HD.
>> For now, I have 12.2-RELEASE-p4 GENERIC on a USB memstick, so I can do
>> some limited testing.
>> FreeBSD 12.2 does not recognize the SATA/RAID controller, which I assume
>> is resposible (in Win10) for accising both drives.
>> The relevant pcoconf line for the controlleris:
>>    none7 at pci0:0:23:0: class=0x010400 card=0x09c51028 chip=0x06d68086 rev=0x00 hdr=0x00
>>       vendor     = 'Intel Corporation'
>>       class      = mass storage
>>       subclass   = RAID
> See if the BIOS offers a choice of configuring the controller as SATA instead of RAID. That worked for me on an Inspiron 1180. (It also made W10 unbootable - apparently each OS occupies its own universe.)

That worked, precisely as it did for you: gpart list shows partitions 
and drives much to my expectations, and Win10 no longer boots.  I can 
boot windows by setting the BIOS config back to RAID.  That's not much 
of a pain.  Now to try installing 12.2-RELEASE on the SSD!

Thank you very much indeed!

Karl L. Dunn
kldunn at hiwaay.net

More information about the freebsd-questions mailing list