Raspberry Pi 4 8GB: Boot Hang, (Simple) Workaround?

Stephan, Corey corey.stephan at marquette.edu
Tue Dec 29 02:08:38 UTC 2020

Pardon me, folks. I am new to these mailing lists. The situation is 
resolved. In case someone else should wonder about the Pi 4 8GB and 
FreeBSD, as of December 28, 2020, here is what I did.

First, I carefully read the following in the recent archives of 



Next, I ran the following steps to replace the incompatible boot files 
in the FreeBSD image:

(1) Burn the most recent FreeBSD 13-CURRENT image for the RPI3 to my SD 
card with Etcher.io, making sure to uncheck the automatic unmount option

(2) fdisk -l
to find the relevant MSDOS partition, which in my case was /dev/sdd1

(3) mkdir /media/d1

(4) mount /dev/sdd1 /media/d1

(5) Copy and paste the outside files linked in the discussion above into 

To be explicit, these are the 3 files that need to be replaced:

(6) sync

(7) umount /dev/sdd1

(8) Insert SD card into Pi and boot

The Raspberry Pi 4 8GB now works wonderfully. Thank you for 
pre-configuring SSH, folks.


On 12/27/20 8:07 PM, Stephan, Corey wrote:
> Hello, fellow open source fans. I am attempting to install FreeBSD on a
> new Raspberry Pi 4 8GB, but I simply cannot get the device to boot. The
> latest Raspberry Pi OS (Raspbian), NOOBS, etc. all work. The Pi's
> firmware and BIOS are up-to-date. The SD card is new, stable, and passes
> verification tests.
> Tried: 13.0-CURRENT from Dec-10, 13.0-CURRENT from Dec-03, 12.2-RELEASE,
> 12.2-STABLE, and 12.1-RELEASE images for the Raspberry Pi 3 (RPI3 images
> are recommended in the FreeBSD Wiki:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__wiki.freebsd.org_arm_Raspberry-2520Pi&d=DwICAg&c=S1d2Gs1Y1NQV8Lx35_Qi5FnTH2uYWyh_OhOS94IqYCo&r=iNvzbjK5Ohtsok8SlKu57qxvToiGa0FLnH3ASaHDLEg&m=AYWabcHnGlOl2dinRxVvxBustQgQKcgNLf3Drq0z-KQ&s=ELaX5Y7uZrhgL3TDNjmiOqCcx24nsWz5fKMGTUocrOI&e= )
> FreeBSD 12-series does not show a boot screen at all, but I more-or-less
> expected as such, since the RPI4 8GB is known to be WIP in 13-CURRENT.
> With 13.0-CURRENT, I reach the boot screen, but I am greeted with the
> following 2 error messages:
> Error 00000044
> This device requires newer software.
> I have read in the FreeBSD subreddit that this has to do with the
> FreeBSD SD card image's bootloader being out of date.
> Does anyone have FreeBSD working on the RPI4 8GB?
> Other: The only advice about this that I have read involves rebuilding
> the FreeBSD SD card image. That is above my knowledge. Moreover, of
> course, I am sure that the aim of everyone here is to bring FreeBSD to
> this popular testing and learning platform :)
> Thank you in advance, everyone. Cheers,
> Corey
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.freebsd.org_mailman_listinfo_freebsd-2Dquestions&d=DwICAg&c=S1d2Gs1Y1NQV8Lx35_Qi5FnTH2uYWyh_OhOS94IqYCo&r=iNvzbjK5Ohtsok8SlKu57qxvToiGa0FLnH3ASaHDLEg&m=AYWabcHnGlOl2dinRxVvxBustQgQKcgNLf3Drq0z-KQ&s=F_LJ9jphDBKE5szcWV_UGykNZzkyX8-Bft8oBJtSg30&e=
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list