5.25" Floppy disk drive not recognized

Christoph Kukulies kuku at kukulies.org
Fri Aug 14 13:40:59 UTC 2020

Fine. There may be many solutions. Actually I’m trying to use the tools I have nd not buy extra hard- and software.

I might also buy a used ISA-bus computer with a VGA Monitor :)

FreeBSD always has been  a good platform to experiment at low level.

Meanwhile I’ve proceeded a bit as can be seen in a previous post. Only this is a riddle to me:

# dd if=/dev/fd0 of=fd_dump
dd: /dev/fd0: Device not configured
0+0 records in
0+0 records out
0 bytes transferred in 0.000262 secs (0 bytes/sec)

Also # cat /dev/fd0 >dump
cat: /dev/fd0: Device not configured


I recall there were devices like


or some such in earlier times where you could choose the right device.

Also using mtools gives me similar messages:

# mdir
plain_io: Device not configured
init A: could not read boot sector
Cannot initialize 'A:'


> Am 14.08.2020 um 13:10 schrieb Jerry <jerry at seibercom.net>:
> On Fri, 14 Aug 2020 10:10:21 +0100, Steve O'Hara-Smith stated:
>> On Fri, 14 Aug 2020 09:42:34 +0200
>> Christoph Kukulies <kuku at kukulies.org> wrote:
>>> I’m trying to access a 5.25“ floppy disk drive if anyone here knowing
>>> what a „floppy“ disk drive is. :)  
>> 	The last time I used one of those with FreeBSD I installed from
>> it, back then it just worked of course.
> I actually had a friend who needed to copy some very old (obviously)
> data off of a few 5.25" or 3.5" disks. I don't remember off hand which.
> Anyway, he puirchasded a USB floppy drive (they are very cheap) and
> plugged it into the system. I should probably add at this point that he
> was using a Win 10 system. In any case, they system recognized the drive
> and set it up automatically. My friend then proceeded to copy the files
> to the HD. Problem solved, almost. Apparently, not all of the data was
> readable off of the disks, they were well over 10 years old. I believe
> he was going to try and run SpinRite on the damaged drives and see if
> it could recover any data. I have no idea if he ever did, or if it
> succeeded.
> In any case, you might find that solution acceptable.
> -- 
> Jerry

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3363 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20200814/86877d35/attachment.bin>

More information about the freebsd-questions mailing list