gpart And VPS Disk: Disappearing swap Partition

Steve O'Hara-Smith steve at
Fri Jan 19 15:23:42 UTC 2018

On Fri, 19 Jan 2018 08:55:27 -0600
Tim Daneliuk <tundra at> wrote:

> On 01/19/2018 01:59 AM, Steve O'Hara-Smith wrote:
> > 	Try adding -l swap1 to that command viz:
> > 
> > gpart add -t freebsd-swap -l swap1 -i4 vtbd0
> > 
> > 	That *should* cause a /dev/gpt/swap1 to appear and persist
> > through reboots.
> It does cause the label to appear under /dev/gpt, but as before, it


> disappears on reboot.


> > 	Hmm - does vtbd0 exist at all after reboot ?
> Yes, the raw drive and all the partition entries are there.
> This is very strange.  From the OS' point of view, this is just
> another hard drive.  The reason this came up at all is because

	I have to agree, extremely strange. I'm out of good ideas now.

> I got a larger drive assigned to the virtual instance. I was able
> to successfully resize the root ufs volume.  But when I then tried
> to use the last 1G of the drive for additional swap, I ran into
> the problems thus described...

	Hmmm, perhaps there's something about it being the last 1G - try
just adding half of it and see what happens.

Steve O'Hara-Smith                          |   Directable Mirror Arrays
C:\>WIN                                     | A better way to focus the sun
The computer obeys and wins.                |    licences available see
You lose and Bill collects.                 |

More information about the freebsd-questions mailing list