gpart And VPS Disk: Disappearing swap Partition

Tim Daneliuk tundra at
Fri Jan 19 14:55:36 UTC 2018

On 01/19/2018 01:59 AM, Steve O'Hara-Smith wrote:
> 	Try adding -l swap1 to that command viz:
> gpart add -t freebsd-swap -l swap1 -i4 vtbd0
> 	That *should* cause a /dev/gpt/swap1 to appear and persist through
> reboots.

It does cause the label to appear under /dev/gpt, but as before, it disappears
on reboot.

>>   gpart modify -i4 -lswapfs2 vtbd0
>> At this point, I can see the new swap partition.  However, when I reboot,
>> it's no longer there.
> 	Hmm - does vtbd0 exist at all after reboot ?

Yes, the raw drive and all the partition entries are there.

This is very strange.  From the OS' point of view, this is just
another hard drive.  The reason this came up at all is because
I got a larger drive assigned to the virtual instance. I was able
to successfully resize the root ufs volume.  But when I then tried
to use the last 1G of the drive for additional swap, I ran into
the problems thus described...

Tim Daneliuk     tundra at
PGP Key:

More information about the freebsd-questions mailing list