pkg missing dependency question

Jack L. xxjack12xx at
Thu Jul 6 08:13:27 UTC 2017

There's a note in /usr/ports/UPDATING about how to fix this. Search
for mesa-libs and you should be able to find it.

On Thu, Jul 6, 2017 at 12:52 AM, DTD <doug at> wrote:
> I had a lot of issues with firefox. It turns out that in the current setup I
> could have just updated the offending package without breaking anything
> else. I had no confidence in this until I did a from scratch install doing
> xorg, xdm, firefox and xfce. Done in that order it all works. Since I had
> nothing invested in the new system I installed libreoffice, gimp and chrome
> next.
> Both libreoffice and gimp warn that they will replace some packages and
> update others. I think firefox should add this to their package. Since all
> this worked I decided to install libreoffice and gimp on my workstation. The
> libreoffice install deleted thunderbird and updated firefox, replaced a few
> packages and updated others. It worked so I installed gimp with similar
> results. It too worked. At the end of this firefox gave my original sqlite3
> error. Updating sqlite3 fixed this. Chrome did not work but re-installing
> fixed that.
> All that history to explain what I do not understand. In installing chrome I
> got errors about missing dependencies but it works. Running 'pkg check' on
> the updated system gives:
> artemis:/home/doug# pkg check -d  -a
> Checking all packages: 100%
> firefox has a missing dependency: libGL
> libva has a missing dependency: libGL
> tigervnc has a missing dependency: libGL
> webkit2-gtk3 has a missing dependency: libGL
> webkit2-gtk3 has a missing dependency: libEGL
> webkit2-gtk3 is missing a required shared library:
> xdriinfo has a missing dependency: libGL
> xorg-server has a missing dependency: libGL
> xorg-server has a missing dependency: gbm
>>>> Missing package dependencies were detected.
>>>> Found 3 issue(s) in the package database.
> pkg: No packages available to install matching 'libGL' have been found in
> the repositories
>>>> Summary of actions performed:
> libGL dependency failed to be fixed
> libEGL dependency failed to be fixed
> gbm dependency failed to be fixed
>>>> There are still missing dependencies.
>>>> Try fixing them manually.
>>>> Also make sure to check 'pkg updating' for known issues.
> On the from scratch system 'pkg check' shows no errors. Doing
> 'pkg info -x libGL' on both systems gives:
> libGLU-9.0.0_3
> libglade2-2.6.4_8
> libgltf-0.0.2_6
> On the updated system everything works except gnumeric (I have not
> re-installed) and a note-pad program (xpad) does not highlight selected
> text. That is the same on both systems.
> What and how should I fix things manually?
> _____
> Douglas Denault
> doug at
> Voice: 301-217-9220
>   Fax: 301-217-9277
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list