openssh-portable under 10.3-RELEASE

Eduardo Lemos de Sa eduardo.lemosdesa at
Tue Apr 18 22:07:53 UTC 2017


I tried to upgrade openssh-version from 7.4p1 to the newst 7.5p1. First, I
used the same usual procedure:

1) downloade 7.5p1 from
2) tar -zxvf openssh.tar.gz file
3) cd openssh-7.5p1 directory
4) ./configure (I edited Makefile to change default dir to /usr instead
/usr/local and sshdirconfig to /etc/ssh instead {something}/etc, as I
always did in another versions)
5) gmake clean && gmake (no error or problems)
6) But, when I did sudo gmake install I got a error : segmentation fault
(core dump at line 372)

Ok, I do not how to solve this problem, thus I solved to install
/usr/ports/security/openssh-portable (I checked, this is the 7.5 version).
I installed it with no problems:

ssh -V showed me 7.5 version

but, sshd -V gave back 7.4 version !! (the old version that I got compile).

I tried to install openssh-portable in another 10.3-RELEASE and got the
same result.

Please, could someone point where I am wrong or point to me how to compile
(without using port facilities) openssh-7.5p1?

Thank you in advance



Eduardo Lemos de Sa
Professor Titular
Dep. Quimica da Universidade Federal do Paraná
fone: +55(41)3361-3300
fax:   +55(41)3361-3186

More information about the freebsd-questions mailing list