openssh-portable under 10.3-RELEASE

Herbert J. Skuhra herbert at
Wed Apr 19 10:09:21 UTC 2017

Eduardo Lemos de Sa skrev:
> Dear
> I tried to upgrade openssh-version from 7.4p1 to the newst 7.5p1. First, I
> used the same usual procedure:
> 1) downloade 7.5p1 from
> 2) tar -zxvf openssh.tar.gz file
> 3) cd openssh-7.5p1 directory
> 4) ./configure (I edited Makefile to change default dir to /usr instead
> /usr/local and sshdirconfig to /etc/ssh instead {something}/etc, as I
> always did in another versions)

Why do you edit Makefile? There is --prefix and --sysconfdir.
Check ./configure --help for more options.

Don't install to /usr.

> 5) gmake clean && gmake (no error or problems)
> 6) But, when I did sudo gmake install I got a error : segmentation fault
> (core dump at line 372)

Show more lines of the error!

> Ok, I do not how to solve this problem, thus I solved to install
> /usr/ports/security/openssh-portable (I checked, this is the 7.5 version).
> I installed it with no problems:
> ssh -V showed me 7.5 version
> but, sshd -V gave back 7.4 version !! (the old version that I got compile).

gmake install didn't complete. Obviously only ssh was overwritten with
the new version:

 # ls -l `which ssh`
 # ls -l `which sshd`

The port installs openssh to /usr/local.

> I tried to install openssh-portable in another 10.3-RELEASE and got the
> same result.
> Please, could someone point where I am wrong or point to me how to compile
> (without using port facilities) openssh-7.5p1?

What's wrong with the port?

Either change your PATH, set an alias for ssh or run /usr/local/bin/ssh.

To activate the sshd from ports replace sshd_enable="YES" with
openssh_enable="YES" and start/stop the service.


More information about the freebsd-questions mailing list