hplip error: No module named sip

Polytropon freebsd at edvax.de
Sat Apr 15 19:07:17 UTC 2017

On Sat, 15 Apr 2017 05:22:31 +0000, Manish Jain wrote:
> > HP Deskjet 1110, I assume?
> Actually, it is HP DeskJet 1112, but it always identifies itself as HP 
> DJ 1110.

It belongs to the same product family, so I assume internally
several devices share a comparable firmware (which maybe even
have zhe same code in parts).

> > However, hplip support seems to be okay for this model:
> > 
> > http://hplipopensource.com/hplip-web/models/deskjet/deskjet_1110_series.html
> This USB printer works fantastically with primary and secondary boxes 
> (both FreeBSD 10.3/11). I have never had a problem with this printer 
> printing with FreeBSD::hplip.

Good combination - especially when you can actually _confirm_
that it works (better than "it should work").

> >> To the best of my knowledge, the printer does not show up in the output
> >> of usbconfig.
> I checked the output of usbconfig by doing this : I ran usbconfig twice, 
> first time with the printer on; and then a second time with the printer 
> switched off.
> a) The first run does not produce identification for any HP/Hewlett 
> Packard device
> b) Both runs produce exactly the same output.

Did you check the dmesg output? When you attach (or power on)
the printer, some new lines should be added. Depending on the
printer, they could look like this:

	ugen4.3: <Samsung Electronics Co., Ltd.> at usbus4
	ulpt0: <Samsung Electronics Co., Ltd. CLX-216x Series,
		class 0/0, rev 2.00/1.00, addr 3> on usbus4
	ulpt0: using bi-directional mode

This is a Samsung CLX-2160 color laser printer. You should be
able to quickly spot similar lines in dmesg output. I'd say
that is the easiest way to determine if the kernel did pick
up the device correctly, which is the _requirement_ of other
software components being able to do anything with it.

(Sidenote: This printer doesn't work with CUPS, but I'm using
the foo2zjs filter and pipe its output into /dev/ulpt0 from
a PS source, and that works. With system lpd, it would easily
be possible to add that printer, but as I'm using it as a
printer only a few times a year, I'm too lazy to implement
this properly.)

> > So the printer actually gets recognized, and CUPS can configure
> > it? It so, what's the point of using hp-setup additionally?
> Now it gets interesting. On neither my primary box nor my secondary box 
> have I succeeded in printing to this printer with CUPS. I have always 
> had to delete the CUPS queue and print with hplip.

With current CUPS and hplip (and maybe hpijs?) it should work
out of the box. I could achieve this recently with a new HP
inkpee printer - CUPS detected it automatically, loaded the
appropriate drivers and filters, and it worked immediately.

> On this tertiary box, it turns out that printing with CUPS is cool : - )

It's not that bad. The only case that gets you headaches is
when the autodetection does not work and you have no idea what
to enter at the "device URI" input field. ;-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list