Having trouble printing to my HP OJ Pro 8600 all-in-one

Ben Woods woodsb02 at gmail.com
Wed Nov 23 05:06:12 UTC 2016

On 23 November 2016 at 12:22, Patrick Mahan <mahan at mahan.org> wrote:

> All,
> System info:
>     CPU: Intel I7 w/8 cpus @ 3.20 GHz
>     MEM: 12 Gbytes
>     HDD: 1 TB Seagate Barracuda (FreeBSD is on a 500G partition)
>     OS: FreeBSD 9.3-RELEASE-p21
> I just update my binary packages (after much much pain) since they were
> so out of date.  One of the items that seemed to drastically was CUPS.
> I had CUPS-2.0.1 and now have CUPS-2.2.1, but it seems I have lost all
> printing ability.  I re-installed all available cups packages (except
> client,
> can't see where that exists) along with gutenprint and hplip.  I see on
> the ports page that there a secondary package called hplip-plugins but
> pkg will not install it as it says it cannot find any package matching
> that name.
> Cups sees the printer, it seems up, but when I attempt to print a test
> page, I get the following error:
>    Unable to print test page:
>           Unsupported format "text/plain".
> Looking in /usr/local/etc/cups and I don't see any definition for
> "text/plain".  Also, the cups filter in the .ppd for the printer
> is set to "application/vnd.cups-raster 0 hpcups", but I can find
> no definition of vnd.cups-raster nor hpcups.
> Tried googling and most of the solutions are targeted for Linux
> platforms and are packages that I no longer see in the ports tree.
> Any pointers, suggestions, how to's are appreciated.  This has been
> the main print server in my office and a couple of colleagues with
> Apple devices (iPads, iPhones and Macbooks) depend on it for printing.
> Thanks,
> Patrick

What make/model of printer do you have? Is it supported with or without the
plugin (check at link below):

Have you tried removing the printer from the config, and re-adding it?

hplip-plugin is not available as a package because of license restrictions.
It can be installed from ports (make sure the hplip-plugin ports version
matches the hplip package version).

Don't follow the instructions on how to install the plugin from the hplip
website, just install it from ports if required.


More information about the freebsd-questions mailing list