Possible bug with SCTP and iperf3?

Eduardo Morras emorrasg at yahoo.es
Mon May 30 09:17:02 UTC 2016

On Sun, 29 May 2016 14:45:14 -0400
Manas Bhatnagar <b.manas.88 at gmail.com> wrote:

> Hello,
> I experienced a hard reset of a system recently, running FreeBSD
> 10-RELEASE, while running iperf3. I do not know much about SCTP nor
> iperf3, I was just fiddling around with iperf3 arguments. These are
> the commands I ran:
> iperf3 -c $IP -P 32 -t 60
> iperf3 -u -c $IP -P 32 -t 60
> iperf3 --sctp -c $IP -P 32 -t 60
> iperf3 --sctp -c $IP -P 4 -t 60
> iperf3 --sctp -c $IP -t 60
> iperf3 --sctp --nstreams 64 -c $IP -P 32 -t 60
> iperf3 --sctp --nstreams 2 -c $IP -P 32 -t 60
> What I remember is that the second last command would not show any
> data as being transferred and when I ran the last command, the system
> running the iperf3 server did a hard reset.

How do you run the server? Had you a log file? Did you run it as root? Try:

%iperf3 -s -D -V --logfile filename

Can you run the last 2 with -V -R --get-server-output --logfile filename?

%iperf3 --sctp --nstreams 2 -c $IP -P 32 -t 60 -V -R --get-server-output filename

Didn't -P for tcp/udp connections only for emulate sctp multistream capability? AFAIK you don't need both.

> I don't know if this is a bug or not but it seems to my inexperienced
> eyes like it is something that could be used maliciously to bring down
> a system running 'iperf3 -s' and so I thought it would be best to
> share this with the mailing list.

Thanks to you.

> Thank you,
> Manas

---   ---
Eduardo Morras <emorrasg at yahoo.es>

More information about the freebsd-questions mailing list