Possible bug with SCTP and iperf3?

Manas Bhatnagar b.manas.88 at gmail.com
Sun May 29 18:45:15 UTC 2016


I experienced a hard reset of a system recently, running FreeBSD
10-RELEASE, while running iperf3. I do not know much about SCTP nor
iperf3, I was just fiddling around with iperf3 arguments. These are
the commands I ran:

iperf3 -c $IP -P 32 -t 60
iperf3 -u -c $IP -P 32 -t 60
iperf3 --sctp -c $IP -P 32 -t 60
iperf3 --sctp -c $IP -P 4 -t 60
iperf3 --sctp -c $IP -t 60
iperf3 --sctp --nstreams 64 -c $IP -P 32 -t 60
iperf3 --sctp --nstreams 2 -c $IP -P 32 -t 60

What I remember is that the second last command would not show any
data as being transferred and when I ran the last command, the system
running the iperf3 server did a hard reset.

I don't know if this is a bug or not but it seems to my inexperienced
eyes like it is something that could be used maliciously to bring down
a system running 'iperf3 -s' and so I thought it would be best to
share this with the mailing list.

Thank you,

More information about the freebsd-questions mailing list