partition boot problem

Polytropon freebsd at
Wed Mar 30 03:53:20 UTC 2016

On Tue, 29 Mar 2016 19:47:18 +0000 (UTC), walter via freebsd-questions wrote:
> Hello !
> Here is the problem I encounter: I recently mounted a freebsd partition
> in rw mode by mistake under openbsd and since I can no longer boot freebsd.
> I can only mount partition and list files UNDER OpenBSD and that's all.
> I tried fsck_ufs without any options (from freebsd livecd) without success
> and I can't mount the partition anymore(from freebsd). May be someone meet
> the same problem and has solved it.Thanks for any help !
> message of fsck:
> "invalid disklabel, segmentation fault"
> when I try to mount (from freebsd livecd):
> "Failed to read ROOTINO directory block 13280
> cannot read blk: 320
> unexpected soft update inconsistency"  <=== 

Strangely I cannot find the error message text you presented. Is this
a check from the FreeBSD live system? Which OS version?

How has the disk been initialized (MBR or GPT or ZFS)?

What exactly did you do (example of commands)?

But it looks like this (given the few informations above):

There are two steps to do: First is to re-initalize the boot block
of the disk (boot0cfg, maybe fdisk -BI), and the partition has to
be successfully (!) fsck'd and marked clean (fsck -f).

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list