Non working NIC

Doug Hardie doug at
Thu Aug 18 01:17:37 UTC 2016

> On 17 August 2016, at 16:58, Polytropon <freebsd at> wrote:
> On Wed, 17 Aug 2016 16:32:20 -0700, Doug Hardie wrote:
>>> On 17 August 2016, at 16:05, Polytropon <freebsd at> wrote:
>>> On Wed, 17 Aug 2016 15:56:15 -0700, Doug Hardie wrote:
>>>> Added a new NIC (rl0).  Removed any reference to msk0 in rc.conf. 
>>>> Set rl0 for DHCP.  Same result, but some additional messages:
>>>> Starting Network: mske0
>>>> Starting Network: rl0
>>>> rl0: link state changed to up
>>>> Starting Network: lo0
>>>> Starting dhclient
>>>> rl0: not found
>>>> exiting
>>>> I am out of ideas here.  How can I figure out what is going on and correct it?
>>> This almost looks like a problem with the contents of rc.conf.
>>> Can you show all the relevant lines?
>> I switched to a minimal rc.conf:
>> fsck_y_enable="YES"
>> background_fsck="NO"
>> dumpdev="NO"
>> hostname="steve"
>> ifconfig_rl0="DHCP"
>> sshd_enable="YES"
>> Same results.
> No errors in this file. However it's interesting that (if I remember
> the thread so far) you reported the disappearing of a network interface
> with two different devices... however, there's something strange about
> the message: when I try to run dhclient for a network interface that
> does not exist on my system, I get this:
> 	# dhclient fxp0
> 	ifconfig: interface fxp0 does not exist
> 	fxp0: not found
> 	exiting.
> Note the ifconfig-related line. And if you run "ifconfig -a" and the
> interface _is_ listed, this makes the whole thing even more strange...

I created the following code:

#include <stdio.h>
#include <sys/types.h>
#include <sys/socket.h>
#include <ifaddrs.h>

int main (int argc, char *argv[])
        int rc;
        struct ifaddrs *ifi;

        rc = getifaddrs (&ifi);
        printf ("rc = %d\n", rc);

Compiled it with debugging and ran it.  after the getifaddrs call (it returned 0), there were 3 entries in the table.  All 3 have the name of "". 

I commented out the networking calls in rc.conf, rebooted the machine and then ran the code.  Same result.  I rebooted in single user mode and ran the code and the same results.  The boot process is not setting the interface names properly.  Whats even more fascinating about this is I have upgraded other machines (although they are newer) from 9.3 to 11.0-RC1 and they worked just fine.

More information about the freebsd-questions mailing list