Non working NIC

Doug Hardie doug at
Wed Aug 17 22:56:23 UTC 2016

> On 13 August 2016, at 17:39, Doug Hardie <doug at> wrote:
>> On 13 August 2016, at 15:45, Doug Hardie <doug at> wrote:
>> I just upgraded an older PC to 11.0-RC1.  Everything went fine except the msk0 device is not found.  Neither is lo0.  Its as if networks never got started.  However, running netif start does nothing.  msk0 is found in the hardware during boot and it appears to get all the proper values.
> Some more information.  I finally found a keyboard with scroll lock.  The output shows
> Starting Network: msk0
> Starting Network: lo0
> Right after that is:
> route: writing to network socket: network is unreachable
> It appears that the network doesn't start, but is not logging an error.  The rc.conf file is the same one used in 9.x which worked.  I did try converting from fixed IP to DHCP, but that made no difference.  msk modules are in the kernel.

Added a new NIC (rl0).  Removed any reference to msk0 in rc.conf.  Set rl0 for DHCP.  Same result, but some additional messages:

Starting Network: mske0
Starting Network: rl0
rl0: link state changed to up
Starting Network: lo0
Starting dhclient
rl0: not found

I am out of ideas here.  How can I figure out what is going on and correct it?

More information about the freebsd-questions mailing list